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OverviewOverview
This tutorial describes the steps in creating new projects 
for the M16C using two different methods.

The first method uses the SKP project generator, that will 
create an empty project. 
The second method will provide step by step instructions 
on creating a project with existing source files.

To get the most out of the SKP including the development 
tools, check out the references at the end of this tutorial.
Note: This tutorial assumes the user has done the following:
1. Followed the ‘Quickstart Guide’ 
2. Installed the SKP files, examples, and software tools in the default directories.
3. Reviewed Tutorial 1.
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Starting HEWStarting HEW

From the Windows Start menu, click on
Programs > Renesas High-performance Embedded Workshop>

High-performance Embedded Workshop
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Creating a Project WorkspaceCreating a Project Workspace

When HEW starts up, you will be prompted to select a workspace. By 
default, ‘Create a new project workspace’ option is selected.

1. Ensure 
this option 
is selected.

2. Click on 
‘OK’ button.
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Creating a New Project with the Creating a New Project with the 
SKP project generator (1/4)SKP project generator (1/4)

2. Select 
‘M16C/1N 
Starter Kit 
Plus’ as the 
project type.

3. Enter ‘Tutor2_pg’.

Note: This is the directory where 
the project will be created, 
‘C:\HEW3\Tutor2_pg’.

1. Select M16C.

5. Click on ‘OK’ button.

4. Verify Renesas 
M16C Standard is 
selected.
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Creating a New Project with the Creating a New Project with the 
SKP project generator (2/4)SKP project generator (2/4)

1. Select 
‘Empty Project’.

Note: The other project selections (Verify SKP and Sample Code) allow you to 
test the SKP and evaluate the MCU peripherals and features using pre-built 
sample code.

2. Click on ‘Next’ 
button.
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Creating a New Project with the Creating a New Project with the 
SKP project generator (3/4)SKP project generator (3/4)

Note: Step 2 shows all the files that will be added to the new 
project and their description.

1. Click on ‘Finish’ 
button.
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Creating a New Project with the Creating a New Project with the 
SKP project generator (4/4)SKP project generator (4/4)

1. Click on ‘OK’ button.

The project generator information is shown once the project 
has been created.
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HEW after Creating a New Project using the HEW after Creating a New Project using the 
SKP project generatorSKP project generator
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SKP project generatorSKP project generator
Summary (1/2)Summary (1/2)

The following is a summary of what happens when creating a new project 
using the SKP project generator Empty Project:

1. The following files are created in the workspace or project directory (in this 
example, under C:\Hew3\Tutor2_pg):
� A copy of the user startup (ncrt0_1Nskp.a30 and sect30_1Nskp.inc) files.
� A .c file (main_1Nskp_template.c) that contains the main function.
� Copies of the SKP header files (sfr_1N.h, skp_bsp.h, and skp_lcd.h) 

included in the .c file.
� A copy of the sfr_1N.a30 file so SFR labels are visible in KD30.

2. Links the startup files first as shown in the “Linking the startup files first” slides 
(slides 25 & 26).

3. Configures the external debugger to launch KD30 as shown in the “Launching 
KD30 from HEW” slide (slide 28).

4. Adds the phase to generate a hex file when building a project as shown in the 
slide “Generate a hex file for the Programmer” (slide 29).
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SKP project generatorSKP project generator
Summary (2/2)Summary (2/2)

The project structure 
and files created 
when using the SKP 
project generator are 
shown here.



12

Creating a New Project EnvironmentCreating a New Project Environment
The SKP project generator simplifies several steps in creating a
new project but what if you already have source files? The 
following slides will walk you through the following:

• Creating a new workspace from scratch
• Adding source files
• Setting up the software development environment including 

linker, build, debugger, and programming configuration
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Creating a New Project (1/8)Creating a New Project (1/8)

1. Select 
‘Application’.

4. Enter ‘Tutor2’ 
as name of the 
project.

2. Browse to, or enter, 
‘C:\MTOOL\SKP16C1
N\Sample_Code’.

5. Leave as is 
(i.e. ‘Tutor2’).

3. Select M16C.

7. Click on ‘OK’ button.

6. Verify Renesas 
M16C Standard is 
selected.

Select ‘New Workspace’ from the File menu…
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Creating a New Project (2/8)Creating a New Project (2/8)

2. Select 
‘M16C/10’.

1. Leave as is.

3. Click on ‘Next’ button.
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Creating a New Project (3/8)Creating a New Project (3/8)

Note: 1. Differences between Default and USER Startup files is 
discussed after the project is created.

1. Select ‘M16C/10’.
2. Leave as is.
3. Select ‘USER’1.

4. Click on ‘Next’ button.
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Creating a New Project (4/8)Creating a New Project (4/8)

1. Select ‘None’ as we 
already have a file 
with the main() 
function.

2. Click on ‘Next’ button.
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Creating a New Project (5/8)Creating a New Project (5/8)
The stack settings are grayed out because USER startup file was 

selected (see Creating a New Project 3/8 ). If DEFAULT startup 
file was selected, these settings become available.

1. Click on ‘Next’ button.



18

Creating a New Project (6/8)Creating a New Project (6/8)

1. Select ‘KD30’.

2. Leave as is.

3. Click on ‘Next’.
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Creating a New Project (7/8)Creating a New Project (7/8)
We already have the source files and selected USER startup files

(see Creating a New Project 3/8  and 4/8 ) and so, there are no 
source files that will be generated.

1. Click on ‘Finish’ 
to complete project 
creation process…
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Creating a New Project (8/8)Creating a New Project (8/8)
A project summary is displayed to indicate a successful creation of 

the new project, tutor2.

1. Click on ‘OK’.
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HEWHEW
After creating the project, HEW will look similar to the figure below. 
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Default and User (SKP) Startup FilesDefault and User (SKP) Startup Files
Except for comments, the differences between the default (ncrt0.a30 and 
sect30.inc) and user (ncrt0_1Nskp.a30 and sect30_1Nskp.inc) startup files 
are listed below:

Ncrt0.a30
� BCLK – Set to f1 (div by 1) of Xin (BCLK = Xin frequency) in user file.
� Stack sizes – Smaller (0x100) in user file [default at 0x300].
� Heap size – 0 (no heap size) in user file.
� Vector Base Address – 0xFF800 for (M16C/1N) in user file [default at 0xFFD00 

(M16C/62)]
� Device Package – set to 80-pin package
� Section Allocation – Calls user sect30 file (sect30_28skp.inc) [default calls 

default sect30.inc].
� Standard I/O Initialization – No initialization in user file (done using mcu_init 

from main()) [default file calls _init routine].

Sect30.inc
� Variable Vector Definition – Simplified and described in user file

Note: You can use the default startup files but ensure that you understand the how to 
make the necessary modifications. The customized startup files for the SKP can 
be found under C:\MTOOL\SKP16C1N\Sample_Code\Startup_files directory.
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Adding Source Files (1/2)Adding Source Files (1/2)
1. From HEW’s Project menu, select Add Files and the Add Files dialog box is 
displayed.

3. Select main_tutor2.c and 
ncrt0_1Nskp_tutor2.a30.

2. Browse to C:\MTOOL 
\SKP16C1N 
\Sample_Code\Tutor2_src
folder, which contains the 
source codes for this 
tutorial.

4. Click on Add.
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Adding Source Files (2/2)Adding Source Files (2/2)
After adding source files, HEW’s workspace will look like the figure below. 

1. To display dependencies per source file, right-
click on the Workspace window, and click on the 
Configure View. 

2. Click on check boxes in 
Configure View dialog box.
3. Click on OK button.

Displaying the source file 
dependencies this way makes 
it easier to verify if the header 
files are included before  
building the project.
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Linking the Startup File First (1/2)Linking the Startup File First (1/2)
After checking dependencies, NC30 must be setup to compile and link the startup 
files first. The startup files contain information on memory addresses and sections 
which the linker uses to place the code at the correct addresses.

4. Select  
Relocatable 
files.

1. Select Renesas M16C 
Standard Toolchain from 
the Option menu and 
this window is displayed.

3. Click on Link tab.

2. Select All 
Configurations.

5. Click on Add.
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Linking the Startup File First (2/2)Linking the Startup File First (2/2)
1. Select Configuration 
directory.

2. Enter the startup 
source file, i.e. 
ncrt0_tutor2.

4. Click on OK.

3. Click on OK.
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Building (compile & link) the ProgramBuilding (compile & link) the Program

If there are no errors, you can try running the program on the SKP16C1N Board 
using the ICD and KD30 Debugger.

Look at the Output window and check 
whether any errors or warnings occurred. 

1. With the workspace name in the 
Workspace window highlighted, click 
on the build icon to build the program.
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Launching KD30 from HEWLaunching KD30 from HEW

To launch (and download .x30 
file) KD30, click on this icon. 

KD30 can be launched directly from HEW, but HEW must be 
configured as shown below. 

1. Select Customize from 
from the Tools menu.

2. Click on Debugger tab
3. Select Other external 

debugger.
4. Locate KD30 from 

C:\MTOOL\KD30 folder.
5. Enter -LOAD=$ 

(CONFIGDIR)\$(PROJECT
NAME).x30.

6. Click on OK.
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Generate a hex file for the ProgrammerGenerate a hex file for the Programmer
After building a program, a file with an .x30 is generated. For this example, 
‘tutor2.x30’ is generated. This .x30 file can be downloaded using 
KD30. However, device programmers, including the FoUSB 
Programmer, use hex files in Motorola or Intel format. 

1. To generate a hex file 
during the build process,  
select Build Phases from 
the Option menu.

2. Click on M16C Stype
Converter checkbox.

3. Click on OK.

With the feature enabled, a hex (.mot) file is created when building the project. 
Look for a Tutor2.mot file under C:\MTOOL\SKP16C1N\Sample_Code\Tutor2\
Tutor2\Debug’ folder.
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End of Tutorial 2End of Tutorial 2

This is the end of the tutorial. You can try modifying or 
downloading other sample programs from the 
\Sample_Code directory.  

The completely built tutor2 project can be found in the 
Zip file under C:\MTOOL\Sample_Code\tutor2_src
folder.

Be sure to check out the references on the following 
pages.

Have Fun!!
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References and Recommended ReadingReferences and Recommended Reading
All documents that came with the SKP can be found using the “Document 
Description” from the Start > Programs > Renesas-Tools > SKP16C1N 
menu.

• SKP16C1N User’s Manual: This is a “must read” document! It details all the 
things you need to know on how to use the Starter Kit.

• HEW User’s Manual: To fully understand and get the most out of HEW. This 
is recommended reading.

• KD30 Version X.XX Help: The tutorial only covered the basics of KD30. 
Check out the Help menu to find out all of KD30’s features.

• NC30 Version X.XX User’s Manual: Check this manual out for features 
specific to the NC30 compiler. 

• M16C/1N Datasheet and SKP16C1N Board Schematic: These are required 
to write user application programs.

• RTA-FoUSB-MON User’s Manual: Read this manual to understand how the 
ICD works.
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References and Recommended ReadingReferences and Recommended Reading
• M16C/10/20/60 Series C Language Programming Manual: This is a great 

document for any level of programmer. The first chapter is an intro to C 
programming. The next chapter explains the memory map of C programs on 
microcontrollers and the role of startup programs. 

• M16C/10/20/60 Series Software Manual: This document describes the 
instruction set and timing information for the M16C/20/60 series CPU cores. 

• AS30 Version X.XX User’s Manual: Read this manual if you plan on writing 
programs in Assembly or when making changes to the startup file.

• Application Notes and Sample Programs: Application notes and other 
sample programs can be accessed from Renesas Technology America’s 
website: http://www.renesas.com.


